webCoRE disappeared from SmartThings SmartApps


Apologies in advance if I have selected the incorrect category for this. I’m new to the forum.

For some reason my webCoRE SmartApp has disappeared in the SmartThings app.

I also can’t access webCoRE Dashboard on my web browser as well. The registration code I have saved is not working.


The strange thing is that my pistons are still working, I just can’t seem to access them anymore.

Any help with this would be much appreciated. Please let me know if you need any more information.



I noticed either you don’t have any Smartapps installed or all are missing…

One thing to try, sign out of the app and sign back in. Click on menu > profile > sign out

Unless you have a Samsung phone which I believe doesn’t have the sign out option. In which case, force quit the app and open it again.

See if that restores the apps in the smartapp section.


Hi @jkp, thanks for your reply.

I have just tried signing out and back in (iPhone). No luck, the webCoRE smartapp still seems to be missing. This is the same if I do it on another device (iPad)

I would try to install the smartapp again, but I got to this screen and it says it will install new instance of webCoRE, which I don’t want ideally as I know my pistons are running and I imagine they will continue to run in existing instance alongside any I create in the new instance.


Question… do you have other smartapps installed that are missing from the Smartapps section?


No I’ve only ever used webCoRE.


Does webcore show correctly in the Classic app?

Two things come to mind as to why your instance of webCoRE does not show:

  1. There is a sync issue where you would need ST support to fix.
  2. you have either some type of ad blocker installed such as adguard or have a pihole on your home network that is blocking it. Probably not the case.

If you have webcore showing properly on the Classic app, then my guess is you have some sort of sync issue in which case, you would need to contact ST support to fix.

Lost Pistons migrating from Classic app to new

Please sign in at account.smartthings.com and go to My Locations > smartapps. Normally that list will include one copy of webCoRE at the top level with your pistons nested below it. Do you still see your pistons there?


I had no idea there was a classic app. I’ve downloaded it and can’t seem to log in. Probably because I use a Samsung account to login to SmartThings.

Just to confirm, I am not using any kind of ad blocker or pihole.


On classic app, login as New to SmartThings and use your Samsung account.

But follow @ipaterson instructions as he will help you better than I can :grin:


Hi @ipaterson. Thanks for your reply.

I can see my pistons under one level of webCoRE. However there does seem to be another two listings of webCoRE as well (maybe from when I initiated installing the SmartApp again, including earlier for the screenshot above). Here is what I can see.

Following on from above, I can also see three version of webCoRE in the Classic app.


Thanks, this has affected a lot of people lately… something is disassociating webCoRE and causing additional instances to get added and like in your case it is often more than one. Are you able to sign in to the dashboard with one of those webCoREs in the classic app to get your pistons?


Yes I am! Awesome! Was also able to use that to register the web browser on my laptop too which is even better.

Is there any way to remove the additional instances, and also sync it so it shows up in the new version of the SmartThings app again?


I don’t know what’s wrong with the new app, but you should be able to remove the other instances with the Uninstall option in the smart app. But before you do that, download a backup file from your working dashboard just in case anything breaks.


Wasn’t able to do it in the SmartApp itself, but worked out I could do it from account.smartthings.com.

Thanks very much for your help @ipaterson and @jkp. Now I need to go away and figure out how to pause my TV when my doorbell is pressed. :joy: