WebCoRE push notifications not working (New SmartThings app)


#1

First off I want to say that I played with CoRE a bit about 2 years ago and ended up settling with basic ST routines to meet my automation needs. After installing and toying with webCoRE for a day or so, I am SUPER impressed. This has come a long way. The web interface is fantastic and makes it so much easier to build home automations.

Anyway, I acquired a few new devices recently and decided to make the push for more actual home automation. I now have several pistons running flawlessly for the most part. My only persistent issue is that I’m not able to get any push notifications to to my device.

1) Give a description of the problem
Push notifications do not work on my mobile device. I’m running the latest iOS and the new Samsung Smart Things app. Smart Things Classic is not installed on this device.

Pistons with SMS notifications work as expected, but I would prefer the push notifications via SmartThings app. I have tried using both ‘Send notification’ and ‘Send PUSH notification’ actions with no luck. Additionally I have tried sending the notification as a Value and valid Expression (prefer expressions as I want to include device attributes). When I build a piston and add ‘Send SMS notification’ where I want to actually send a push notification, it works as expected. Which leads me to believe it’s an issue with the webCoRE notification functionality or my device. I have tested the new Smart Things app and successfully received notifications from the Home Monitor module of the Smart Things app (leak sensor, etc). Full notifications are enabled for the Smart Things app on my device.

Again, I do not have the Smart Things Classic app installed or configured. I’m wondering if this might be the issue? I believe I installed webCoRE through the Classic app and never really used it. I have not yet gone so far to reinstall and reconfigure SmartThings Classic, but that’s my next troubleshooting thought beyond asking for help here.

2) What is the expected behavior?
A push notification to my phone.

3) What is happening/not happening?
My phone does not receive a push notification.

4) Post a Green Snapshot of the piston


This is a simple example… The SMS sends but the push does not.

5) Attach any logs (From ST IDE and by turning logging level to Full)
Logs are indicating that the notification was pushed as expected:

|+126ms|║║Calculating (string) Island light level is + (string) 77 >> (string) Island light level is 77|
|+132ms|║║Executed virtual command [Corner Light].sendNotification (3ms)|
|+142ms|║║Calculating (string) Island light level is + (string) 77 >> (string) Island light level is 77|
|+161ms|║║Executed virtual command [Corner Light].sendSMSNotification (12ms)|
|+164ms|║╚Execution stage complete. (98ms)|

From above, I receive the SMS notification but not the push notification. This entire piston is just a basic example of my issue and not intended to use regularly. That said, the push notifications are not working at all in any of my pistons. I wasn’t able to find anyone else with this issue when searching, so I will continue troubleshooting and post my findings here.


#2

hi there,
Can you try chaging WITH SWITCH 2 to LOCATION
meaning,

If switch2 switch changes to ON
With Location
Send SMS …


#3

I appreciate the quick response, Ike!
I tried to use “With Location”, and while ‘Location’ is listed as a Device in my list, I am not able to select it to use in the action. It’s greyed out and my mouse cursor shows a grey ‘cancel’ icon when I mouse over Location. I am not sure why this is but you may be on to something here.


#4

I don’t believe webCoRE is able to send push notifications to STSC at this point, only to Classic.


#5

Thanks, jkp. I think that may be the case. I foolishly deleted ST Classic assuming SmartThings/Samsung was much further along than it is. This is not the first inconvenience I’ve encountered since switching.

I just enabled ST Classic notifications on the wife’s phone (she still has only the classic app) out of curiosity… Sure enough, she is getting the notifications from the piston as expected. Sounds like I will need to reinstall.

I may have missed a note about this in the documentation, but I feel like it is worth noting on the wiki alongside any other know issues with webCoRE functionality and the new Smart Things app.

Edit: For now, jkp’s response is my solution and I have marked his post to reflect that. I just reinstalled the Smart Things Classic app and the notifications are working on my mobile device. Something about having two apps for the same purpose bothers me, but I will just have to deal with that for now. Hopefully STSC catches up eventually.