webCoRE Update v0.3.108.20180906 - restore pistons from backup file, bug fixes


This is fixed now, just force reload the dashboard. Sorry but I don’t have any insight into your original observations about wait statements.


Wasn’t expecting any, at least not yet. Just putting it out there in case anyone else observes anything similar.


Ditto, same issue…


Same here. and It seems Ive got pistons malfunctioning saying they will never fore because not subscribed when they were working just fine days ago.


I’m having issues with waits as well, same as above.

The log shows that it’s requesting a wake up, but Next scheduled time shows never:


I also don’t show any updates available in IDE.


Count me in as another.

Pulled perhaps due to the above noted issues?


I’m not aware of any issues caused by the latest release and it has not been pulled from GitHub.


Seems that the GitHub connection for you and a few others is broken. In the past people have always had success with disconnecting from GitHub in the IDE and reconnecting, but that is a lot of work if you have multiple repos set up.

Would you please instead try adding a new repository to see if that triggers ST to check for the update? My Smart Apps > Settings > Add new repository with the fields ady624 webCoRE staging. You don’t need to install anything from that repository, I just want to see if adding it triggers ST to check for updates on ady624/webCoRE/master.


Sorry, I was just noting the comments about issues with Waits and others with piston issues.


This morning, without doing anything suggested here I am now seeing an update. I guess ST had a hiccup with Github yesterday.




Was able to update this AM. and all problems seemed resolved. Man I wish I had this a week ago. Lost two very important large pistons that I now have to try and rebuild. thanks for doing this!


Not sure of the circumstances, but were they accidentally deleted? If you haven’t made any major changes like switching to a new instance of webCoRE then if they happened to have back up enabled they can still be restored from your private backup bins. If you think that might be the case please PM me and I can help you to restore those by looking up the backup codes.


As others have already reported, GitHub updates seem to be working great today. All is updated and well. Thanks!


Yes, I was deleting a user that was associated with both the pistons and it actually deleted the piston. No major changes so yes it would be much appreciated if we could recover them.


Is there anything special to be done for this update for use with Hubitat?


After updating to this release from the SmartThings IDE, then logging out and logging back in to dashboard.webcore.co I see a message that there was an error loading piston data. I see none of my existing pistons on the dashboard anymore and most of the commands on the left menu do not work. I tried deleting all browser cookies, same result. Tried using Firefox which I never use, same result. Tried browsing on my phone, same result. Error about loading piston data and nothing shows up. This should never, ever, ever, ever happen from a simple IDE upgrade!!!?!?! WTF!?!? Tell me how to fix and get my pistons back ASAP.

Thank you.

Cannot load dashbord after updating

Discussion continued here


My apologies if I’ve missed it in the thread, but I’m trying to find out about the restoration process. When restoring/importing does it create an entirely new piston or will it replace the existing one with the same name?


It will always create a new one.

If you restore a piston that was referenced in an Execute Piston action, that Execute Piston action will need to be updated even if the restored piston has the same name because it has a new id.