Cannot load dashbord after updating


Continuing the discussion from webCoRE Update v0.3.108.20180906 - restore pistons from backup file, bug fixes:

webCoRE Update v0.3.108.20180906 - restore pistons from backup file, bug fixes

@andyhawks what error do you see in the Live Logging tab at when you try to load the dashboard in your browser?



df6a189e-b2a6-4c83-9667-6dd34557e0c5  5:38:08 PM: info smartapp_pause called by smartAppName=webCoRE, value=250, smartAppVersionId=66e05108-407b-463e-8585-5ed820e60559
df6a189e-b2a6-4c83-9667-6dd34557e0c5  5:37:50 PM: error java.lang.reflect.UndeclaredThrowableException @line 1699 (listAvailableDevices)  

…many (30+) instances of the smartapp_pause notification follow the java exception error


Well that’s new…

Try going into your webCoRE smart app and updating the selection of devices at Settings > Available devices > Available devices. I can’t tell much about the actual cause here but perhaps a device that webCoRE thinks it has access to is no longer available. You may be able to just open the Available devices screen and press Done without making any changes.

If that doesn’t help with the dashboard issue then try Clean up and rebuild data cache also on the Settings screen of the smart app.


@ipaterson I went to Settings > Available devices > Available devices, went into each section , then saved. Same result. I did notice an additional ‘invalid token’ error in the logs preceding the device listing error this time:

df6a189e-b2a6-4c83-9667-6dd34557e0c5  5:59:37 PM: error java.lang.reflect.UndeclaredThrowableException @line 1699 (listAvailableDevices)
df6a189e-b2a6-4c83-9667-6dd34557e0c5  5:59:17 PM: error Dashboard: Authentication failed due to an invalid token

…and when I logged out and back in I got hit with needing a browser code after I had just entered one.

Is it possible it’s a simple session cookie issue or something similar if I’m getting prompted for the browser code again and the ui was not able to load my data? Not sure how to reset the cookies because I cleared all my cookies after upgrading webcore after I first got ‘error loading piston data’ with the dashboard, so I should have had all fresh session cookies.


Hmm here’s a recent report from someone else with the invalid token error. Seemed the fix was to reset the dashboard password in the webCoRE smart app settings.


I reset my webcore password - no change, still get the same error. Then also reset my Samsung account password - no change, same error.


@ipaterson this resolved itself after 1 full day. Nothing changed on my end, so I am totally unsure what the source of the issue was or how to isolate it any further. I still suspect it was a session cookie issue or something similar so the thread you linked above is probably the best course of action if anyone else has a similar issue, since changing password would force a new session, even though that didn’t immediately work for me.


Odd! Glad to hear that everything is back for you.


I think my issue is similar, it shows that I have pistons running and I confirmed they are but I can’t navigate to them. Should I wait 24 hours and see if they appear? As a test, I tried reimporting one and it just went hidden as well, same on every browser.


Dashboard > Settings > Categories then change your Indoor category from “Hidden” to anything else.


Ah, cool. I skipped over that tab for some reason when I was looking around for a fix. Oddly enough, it wasn’t on “hidden” before I did the update (it was on Large Tiles/Details) and was not on “hidden” after the update. I had to change it several times and save before things came back. In case anyone else stumble on this same scenario. Thanks


Bizarre! Glad it is fixed and thanks for sharing the solution.


FYI @ipaterson I spoke too soon on my issue, it’s not resolved. Dashboard initially loaded fine without the error once, but when I try and load a piston it just spins until I eventually get ‘Sorry, an error occurred while retrieving the piston’. Error in the smartthings logs is same as above, just ‘error java.lang.reflect.UndeclaredThrowableException @line 1699 (listAvailableDevices)’. When I return to the dashboard I receive the notice that there was an error loading piston data. I cleared cache from the phone app, disabled pistons from the phone app, but there was no change to the dashboard. Changed password again via the phone app, no change.


followup, i tried to create a brand new webcore instance. After setting up a new instance on the phone app, I logged out from webcore dashboard and logged in with a registration code for the new instance. Did not see any way to ‘restore from backup’ on the new empty instance using backup file created from the old instance. Went to add my old instance via ‘Register Instance’, put in the registration code, but still only my new blank instance is visible from the dropdown at upper left of the dashboard.

I have no clue how to see my old pistons at this point. Heavy sigh.


I helped someone else today restore their apps from the SmartApps list at As long as you are indeed able to access and create pistons in the new install I can help you with restoring those pistons tomorrow. I’ll be in touch.


tyvm @ipaterson . I did find the new ‘Import from backup file’ option under ‘+ New Piston’.

the first piston I attempted to import with this way method imported as blank aside from the top comment block (could be because I tried this from a separate computer that has not accessed or and got a password auth popup which in turn opened a lastpass yubikey password popup).

subsequent imports seem to be importing ok, other than device GUIDs being preserved. if you have any tips / tricks for preserving device GUIDs across webcore instances when importing from a backup, please let me know! I hope there’s a way to do that, I have 30-40 pistons and hundreds and hundreds of devices and really don’t want to have to go in to each piston and change the GUIDs to the correct new device.


From what I’ve seen the device IDs remain the same as long as you have authorized the new instance for access to all of those devices. For anything that is not authorized you will see the ID rather than device name.


@ipaterson on my second import attempt this is working as expected, GUIDs are correct for devices and other pistons. Still having super-weird session issues with one computer where I can’t see any pistons on the dashboard and get that ‘error loading dashboard data’ error no matter what browser I use, but it’s working just fine on a second computer. Thanks for guiding me through this.


I’m having the exact same problem, and seeing this error:
92f5df3f-160e-4f68-a76d-663c2ef7b751 4:15:07 PM: error java.lang.reflect.UndeclaredThrowableException @line 1699 (listAvailableDevices)