Webcore won't load ["Generated list of devices" slow and loading only one device at a time]


Ever since the latest update, the webcore dashboard will not load. Accessing it through the ST smartapp list or registering a browser both yield nothing. I’ve rebuilt the cache multiple times, cleared cache in the mobile, but nothing has worked. Any suggestions?


Are there errors in account.SmartThings.com Live Logging?


Seems like it’s generating a list for all 171 of my devices and it’s just taking an extremely long time. I wonder if it’s just timing out and that’s when I get an error. I’ve never seen this before.


Yeah something is extremely slow there. It loads devices for up to 10 seconds per request but in your case it’s taking over 12 seconds just to load one device.

This particular behavior was released in 0.3.110 in 2019 since many were having trouble with all ~100 devices in one request timing out. I’ll take a look if there are any related changes since then.


Well it got to 73 devices and then the dashboard loaded. I exited out, and fired up webcore again and it showed the dashboard almost instantaneously. No idea what changed, but it seems to be okay now. Thanks a lot, Ian.


That’s good to hear. I’m taking a look now to see what might have happened between starting and stopping that timer. It looks like probably a temporary platform delay loading any device.


Well, here we go again. I even saved all my piston backup bin codes, deleted webcore, installed it all again, and tried fresh.


I also get this message once I finally get into the dashboard.


If you are willing to debug this, what happens if you extend the timeout from 10 seconds to 15 seconds? Find this line 189 in the webCoRE Storage smart app and change the 10000 to 15000:

// Stop after 10 seconds
if (idx < devices.size() - 1 && now() - time > 10000) {


Fired right up with no errors.


Thanks but how many “generated list of … devices” were logged? I’m curious whether this is something like if allowed to load for 15 seconds it loads 5 or 10 per page or if it gets all 170. Seems like the 10 second delay is all up-front collecting the devices from the smart app settings…

ST mobile app > SmartApps > webCoRE > Settings > Available devices > Available devices > back will force the dashboard to reload your devices.


It hung for about the 15 seconds but then went right in with no error.


Perfect! For now I recommend leaving that 15 second tweak in place. I don’t have a good idea how to solve this otherwise. Usually the problem was that specific devices like Echo Speaks had a ton of data and would time out but seeing this much delay up front is unexpected…


Greatly appreciate the prompt response! Thanks so much.


Hi @ipaterson,

I started having a similar problem after upgrading webCoRE yesterday. After adding any new devices to ST and webCoRE, it takes between 13 and 14 seconds per device for all of my 203 devices to generate. Total time, 46 minutes of spinning until I can access the dashboard.

I added your 15-second tweak. Total time now, 2 minutes.

If I extend the tweak to 20 seconds will that cut the time even further?


ST terminates smart apps that run for 20 seconds or longer so that is likely to push it too far. You can certainly try it but I suspect at least some of those will error out. Maybe ~18 seconds?

I’m curious to hear what seems to work best!


So yeah, glad I found this – sorta been ignoring the lengthy startups but its gotten annoying recently. Added the hack and weee, much faster … Was taking like 10 secs per device and like 45 mins or whatever. Now probably 10-15 secs total. Thanks for the fix!