Wifi dimmable devices unable to read or set level (e.g. Lutron)


Can you share a link so I can follow there? Thanks!


I am having similar issues. Starting a few days ago my WebCoRE pistons have been unable to do anything with dimming/setting levels of lights. I can turn lights on and off, but can’t set them to specific levels. I have TP-LINK HS220 (WiFi device) and Philips Hue lights (via Hue Bridge) which are affected.


Not much to see, but …


So, uh, does anyone have any ideas as to where we might go from here?

As it is now, about half of my house’s automations have been dead for a week and change, and I’m not sure whether anyone on the WebCoRE team has even noticed that this integration is broken?

PS I’m not trying to complain just for the sake of complaining—I’m honestly interested in what avenues we might consider from here.


The issue I’m seeing is any wifi dimming device is failing. In my case Leviton, Lifx and Sengled. On/off works fine. Zigbee and Z-Wave dimmers work fine. Wifi dimming working fine in ST app and native apps. Both WebCore and ActionTiles reacting the same implies a change in ST. I requested support from SmartThings and they said “Go talk to WebCore and ActionTiles.” Haha. I do not have my Lifx bulb included in WebCore so that confirms the issue is based in SmartThings since ActionTiles is behaving in the exact same manner. I’m guessing it will be up to AT and WC to identify the change and adjust.


That’s why I commented that it would be handy if Smart Lighting also had problems. I can’t test it myself.

I’ve opened a thread over on the SmartThings forum to see if anyone else has noticed anything.


This is probably ‘a good thing’ …


I’m really glad I found this thread. I’m having the exact same issue and had already wasted a day trying to figure it out thinking it was a problem on my side. For now I switched everything I could to just turn on and for the stuff I couldn’t (night lights) I created virtual switches that get turned on by my Pistons which in turn trigger a routine on ST to set the dimmer level.


For now I switched everything I could to just turn on and for the stuff I couldn’t (night lights) I created virtual switches that get turned on by my Pistons which in turn trigger a routine on ST to set the dimmer level.

@zl4y3r By chance might you be open to elaborating on the mechanics of how you set up this stopgap for dimming?

Is the idea that you have virtual switches called something like “Living room 50%,” “Living room 60%,” “Living room 70%,” and so on—and then you have your pistons turn on those virtual switches as needed, which then kicks off SmartThings routines to set those light levels?


Following. I too ran into this issue. Device actions are pretty limited as stated by others. No longer have an action to “setlevel”. I will note that I can set level for my hue bulbs but not my caseta wall switches/dimmers.


Likely a very good thing, if it’s this widespread, it sounds like the API’s ST exposes to these external apps. Sounds like it has made it’s way to ST engineers, something I wouldn’t know how to accomplish :smiley: Hopefully a fix will come soon then!


Sounds feasible, but painful :smiley: Good to have options if this doesn’t get fixed soon, but hoping for a quick fix.


It might be a good idea to change the thread title since it happens with other brands as well. Maybe it will get more attention, and get fixed soon :wink:

Lutron Caseta Dimmers are no longer fading on in webcore

This does look rather like an issue at the interface between the ‘new’ and legacy platforms and in particular with the C2C schema integration. If anyone spots it elsewhere then it is worth a shout.

For example if devices using Edge drivers also have issues (I don’t think they do) that would shift the focus.

If devices using a DTH have issues that would shift it even further.




Just my usual post that webCoRE is a legacy app and it will cease to work on the ST platform when they remove support for groovy. Users should start thinking and planning a switch to Routines/scenes and/or Rules API :slight_smile:


Following! I had to switch to my backup routines in the SmartThings app for now. Nothing like the bathrooms lights coming on at 100% (or not at all) at 2 AM.


I think this just got fixed! My TP-Link HS220 seems to be dimming again!


Yup yup—it looks like we’re back in business!


Awesome, same here!