Available Devices not working


All goes well installing from the IDE and updating from the repo.
The issue seems to be inside the Classic app where I firstly see the below which looks correct.

Onto installing Webcore and I see the below after entering password etc.

I get the spinning wheel for a while then the error up the top.

I had previously installed fine and only removed webcore because I would get the spinning wheel when trying to add a new sensor.
Maybe I uninstalled incorrectly and there is something left from the uninstall preventing a new install as I had no issues first time around??
Snapshot from my IDE below



Thank you, I can confirm after updating via git it’s all working for me again.


Still not working for me…


@ady624 wondering if you have any update? I’m really at a loss and about to reset my hub and start all over but worries I’ll be in the same position.


Sorry, just realized the initial setup is done in a different app and I have to update that to split the faulting page out of it. Will update today, sorry for the issues.


@Ganman can you please update to v0.3.10c and try again? Thank you

webCORE Dashboard Completely Broken. Please Help [UndeclaredThrowableException]

Ady, since changing the device values to NaN didn’t really help much in the device loading, can we get that back? ocd is begging :wink:


FYI, @Ganman issue is with installing webcore on AP02 and not about this thread’s topic of available devices.


Yeah, it was brought to my attention about the setup issue from within ST. So I fixed that too. I initially fixed just the page (which normally resides in the storage app). The setup uses the webCoRE parent app, so I fixed that too today. :wink:


@ady624 thank you so much! Working fine now and sorry if I confused the thread with my description of the issue.


I updated my webCoRE in IDE the other day to 0.3.10e and started to have problems.
Some devices that used to be visible are no longer visible and some new ones I have are not visible,

Looks like it might have been this change to break devices up onto two pages for timeout issues in APJ and I’m in Australia. But I never saw any timeout issues previously.

On the first page under Sensors or Actuators I don’t see the device.
The only other option is ‘Devices by Category’ which doesn’t work, just get ‘Something’s Wrong’ in Android and Network Error in IOS.

I’ve tried to roll back to previous version 0.3.10a with a manual install but get ‘Sorry, there was an unexpected error’ when installing the smartapp in SmartThings Classic App.

Edit: Actually with versions a & b I cant install into SmartThings, just get ‘Sorry, there was an unexpected error’.
Versions c,d & e, only able to add devices by sensor or actuator. Selecting ‘by capability’ fails with ‘Something’s Wrong’.
So am missing a few devices.

Any help?



Is there any more info on this not working on AP02?
I guess we need to speak to SmartThings then but what do we need to ask them?


Thanks for leading me here. Me too in Singapore having this same issue as well. Updated to the latest version too.


Did you also lose all pistons? Or is it just some devices not being displayed?


Hi, since the upgrade I am missing some devices and not able to add some new ones.
I cant pinpoint the exact time this occurred because hadn’t logged in for a few weeks but saw the upgrade available in IDE and installed it.

We see now that the devices page is split into two as you advised for your update. We can put devices into Actuators and Sensors and this all works fine. But I also have many devices under other sections which are no longer available.

When we press the third option for ‘Devices by Category’, it fails with ‘Something’s Wrong’ (In Android. In IOS get nothing just fails back to previous page).
So we cant get to the second page to add in the additional devices in the other sections.

I understand that this may be a problem with the AP02 server for Asia Pacific. I reached out to SmartThings to open a support case but got back that this is a 3rd party product that they dont support and see webCoRE instead.

I tried to roll back to 0.3.10a and b but they wont install into the SmartThings Classic App. in c,d,e we cant get to the second page of devices,

Pistons still work fine for the devices that are available through Actuators and Sensors.
For one of my devices which was a TP-Link HS100 wall power plug, I just updated the DTH and added in ‘capability: actuator’, and can now select it. But doesn’t help for the other devices.



So it seems like it this is still timing out we may need to try breaking the capabilities list in half. Seems worth a try at least.


I’m thinking something like this, will post code in a bit for you to test this with 3 pages (6 shown for testing). Each page loads much faster on my account so I think this could help your issue.


I set up a branch in my fork of webCoRE to experiment with solutions to this problem. The first attempt as shown in the previous reply can be installed by copying this replacement code for the webCoRE Storage smart app and pasting to replace all of the current code in your webCoRE Storage smart app at accounts.smartthings.com > My Smart Apps. Then click Save and Publish > For Me. You should now see three pages of capabilities on the select devices screen.

The changes between this and the live release of webCoRE can be seen here

This won’t be a final solution since it seems that ST loses the page arguments when you click back from a device list. Once you select a device the page will be blank possibly since it doesn’t remember which capability group you were viewing - just tap Back to the previous screen rather than Done once you get to this blank page. This is just to see whether splitting can resolve your problem; if so I can implement it in a better way. fixed in the latest update

Device not shown in Available Devices in Webcore Setting

The workaround has been updated to avoid the blank screen after toggling devices. The links above are still accurate but please paste in the latest if you have done so prior to this message.


I can confirm that this solution works great, thank you! :smile:
And I didn’t get problems with blank pages showing.

Now all my devices are back YAY!

Cheers a million.