Available Devices not working


#21

Just tried it again, still not working for me in AU.


#22

I have made a change to break up the lists of devices onto two pages. Turns out building the list of capabilities takes too long in the Asia-Pacific region. This is due to a feature flag that we currently enabled. We are looking into ways to make things faster, until then, use the devices by type primarily - there is a big chance you still won’t be able to access the devices by capabilities but since that’s now in a different sub page, you should be able to at least use the by-type selectors.

Also, sorry it took me so long to fix this. And thanks to one ST employee who also uses webCoRE who found the “fix”.


#23

Does this require an update on the devices running the Samsung app? I can’t see a change in my WebCoRE (no split into two pages, still says something went wrong). It shows “Cast Iron v0.3.10a.20190223”.


#24

You need an update in the IDE for the app. Make sure you also publish. I simply moved the other types into a different page - that may still fail but at least you have a way to use the actuators and sensors which should be all devices, if their DTH is written correctly.

The version is v0.3.10b.20190514


#25

Still having the same issue unfortunately and using the version you mentioned v0.3.10b.20190514

I have removed the 4 groovy in the IDE and re-installed from the repo but same result.

Note this whole process did work for me the very first time I tried to install and I only removed to start over because I could not get back into where a new device needs to be added in the Classic app.

Loved what webcore was doing before and would love to get it back!


#26

What exactly does not work, could you please explain step by step?

Thank you


#27

Thanks. I updated in the IDE and it’s allowing me to select by type.

Strangely,

the version showing in my app is still v0.3.10a.20190223. But it’s certainly behaving as you’ve described - separate sub-page for “select devices by capability”, which times out but is not necessary.

Thanks for all your work on this stuff. WebCoRE is seriously what makes SmartThings shine, and is what wows friends and family enough to consider joining the smart home revolution.


#28

All goes well installing from the IDE and updating from the repo.
The issue seems to be inside the Classic app where I firstly see the below which looks correct.

Onto installing Webcore and I see the below after entering password etc.

I get the spinning wheel for a while then the error up the top.

I had previously installed fine and only removed webcore because I would get the spinning wheel when trying to add a new sensor.
Maybe I uninstalled incorrectly and there is something left from the uninstall preventing a new install as I had no issues first time around??
Snapshot from my IDE below


Thanks
Andy


#29

Thank you, I can confirm after updating via git it’s all working for me again.


#30

Still not working for me…