Dashboard broken


I have been having this issue off and on for years and I’m baffled by why it’s still an issue. Just do a search for the error message “There was a problem loading the dashboard data” and you will see that this has been going on for a long time:

After migrating from the Classic app, I just recently removed all my devices, factory reset my hub and reinstalled webCoRE. I set up one Piston to start and it worked beautifully, as expected. It was nice to start over with a clean setup.

The next day, I decided to get back to setting up some more pistons. I opened my browser, and went to the dashboard and I see the “There was a problem loading the dashboard data” at the top, so I logged out. I opened my SmartThings app, selected Register Browser, and entered the code…then my password. I was taken to the dashboard, but nothing worked and the same error message is at the top.

This has happened to me from time to time in the past and I usually just give up and when I try again a day or so later things work. This time I really needed to set things up this time, so I decided to push ahead to resolve it. Here are the things I’ve tried:

  • 3 different browsers on Mac and PC
  • Going to the dashboard from within the SmartThings app
  • Cleared all webcore.co related cookies in the browser
  • Used the clear cache option in the smartapp inside the SmartThings app
  • Completely uninstalled webCoRE via the IDE and reinstalled it

None of these things have worked, I still get the “There was a problem loading the dashboard data” error.

Is this a known issue? Anyone have any suggestions?


Recent thread on this topic.


Thanks for the link.

Since this is a Meta/Bug topic, here’s a few easy UX improvement suggestions to make user’s lives easier (especially those who are newer)

  • Move the error message from the hard to read gray slide down thingy, to a modal dialog that takes over the screen.
  • Update the messaging to say “There was a problem loading the dashboard data. There are many reasons this could happen. Please check the webCoRE forums to get the latest status”
  • Maybe also add a link to a page to the wiki that lists common reasons for the error and what to do?

Small stuff like this can go a long way to improve the experience.


Because SmartThings is constantly breaking things.

There was a problem loading the dashboard data (August 25, 2020)