Duplicate webcore smartapps in IDE?


1) Give a description of the problem

After updating webcore from repo I seem to have
2 of everything and all are on the latest version aside from the dashboard - one has, one hasn’t.

2) What is the expected behavior?
I used to have one of everything, is this an issue? Do I now need to delete the duplicates?

Could this be because when I first updated I may not have selected all of the apps? I.e. I did not update everything at the same time?

*EDIT having delved deeper, I can identify the newly created smartapps by clicking on the ‘eye’ icon. Is it safe for me to just delete these? Or should I just leave everything as is?

4) Post a Green Snapshot of the pistonimage


Can anyone advise on what I should do here?


One thing to look at but please do not do anything until someone gives you more info on how to proceed. But if you click on the eyeball icon next to each one, it gives you the creation and modification dates for the SmartApps. Perhaps you can match up both sets according to those dates, if by chance they are different for each set. Something to look at but I would highly suggest waiting for perhaps a better path before deleting. I also assume that the one WebCORE with OAuth set to true is the original and working one.

Again, wait for a minion to respond before proceeding.


Thanks @jkp yes you assumed correctly, and I can match the creation dates. Basically all of the duplicates apps show that they were created yesterday (2nd April 18), so it’s easy to see.

The only anomaly is that the purple ‘dashboard’ app did not get the latest update, instead the duplicate dashboard got the latest 3.104 update, and I can no longer update the original.

All very strange. Will wait for a minion as advised!


…Just one other thing - and I’m not sure if it’s relevant - but I’ve started to install Michael Struck’s Ask Alexa Smartapp, I am yet to finish the process and have just got to the app installation stage of the wiki. Not sure if this integration may have caused the duplicates? I’m guessing not, but in the interest of full-disclosure I thought I’d better add that info onto this thread…


Bumping for minion advice :slight_smile:

Need help to delete duplicate Storage child app

Anyone? Would really appreciate some advice before I risk deleting the duplicates myself :cold_sweat:


It’s looking like no one can help me on this, so I’m planning on going ahead with deleting duplicate apps.

Can anyone tell me how to backup my current core pistons? Is it just a case of recording all of the number codes attributed to each one?



I tried to delete the apps but it won’t even let me do that :face_with_symbols_over_mouth: Just got an error 500, internal server error when I tried.Error%20500%20Smartthings

I’d really appreciate some help from a pro here as it looks as though I won’t ever be able to update webcore properly now. Really no idea how this happened…:open_mouth:


Ok got it down to this, but I cannot delete the last 2 duplicates apps…

I’ve un-linked them from Github, but they are seemingly impossible to delete, the ‘webcore’ duplicate app reports:

Error 500: Internal Server Error

Whereas the other ‘piston’ duplicate reports:

This SmartApp can’t be deleted at this time because it is installed by one or more users

In My location-smartapps the duplicate apps don’t appear - it’s just the usual 3 webcore apps - ‘webcore’, ‘webcore storage’ and ‘webcore dashboard’ - which is apparently normal, there are no strange or ghost apps appearing in the indented webcore section…

I have read that some people have managed to delete rougue entries like this by ‘writing over the code with a switch and save then they are able to delete’ - I’m not really sure what this means? What switch should I over-write the code with, could anyone help me understand this?


Do you have two copies of WebCORE pistons in the ST app in Automation: SmartApps?


Hi @jkp thanks for replying again. No I only have a single webcore app in automations/smartapps


Did anyone ever solve this? The same thing just happened to me with the most recent WebCore update.