LIFX integration appears to be gone from the "classic" ST app


It looks like ST got rid of access to LIFX via the “classic” app ( and now I’ve lost control of LIFX via the webCoRE pistons, as well as access within the app.

I tried adding the LIFX API Token within webCoRE, but that didn’t seem to help. Also trying to get the custom DTH installed that apparently will temporarily resolve this issue.

Anyone having these issues and any way to help without switching over to the new app? (I have too many DTH’s and ST is saying we won’t be forced to move over until they work out remaining integrations).

Thank you


why not just remove them and add the lifx lights through the lifx integration in the new app? then add them to webcore


Because I have numerous custom DTH’s that I don’t believe will work in the new app and various integrations that use Raspberry Pi’s to bridge various applications together. I don’t believe these will work with the new app at this point, so I have to stay with the classic app.


Do you have your webCoRE settings integrated with LIFX? Like this? Starting aT post 18 you can see how to go into the settings on webCoRE and integrate LIFX


I’m not sure I want to go down the road of having both apps running right now. ST is saying there should be no issues, so I am not sure what’s going on. Numerous people are reporting issues.


I’m a little confused on this. It appears it’s only for scenes, which I didn’t need, as I had WebCoRE making the scenes. I did link in the LIFX key into the WebCoRE settings, but it still doesn’t give me control of what I used to be able to control with WebCoRE. I didn’t have scenes in LIFX until yesterday (had to do this to cover what WebCoRE was doing before yesterday).

As an update, a ST staff member walked me through a way to resolve this issue, if anyone else is having the same issue. You can keep your classic app with this method. Step 1: download the new app and login. Step 2: Click on the hamburger menu and then the gear icon in the corner. Look for “Connect Services” and then click on it. Look for “LIFX” and tap on that. That should re-connect you. From here, you can go back to the classic app and it should be synchronized (and WebCoRE works with it again, too!)


:slight_smile: Luckily, I didn’t have to remove the installs - it just re-established the cloud link.


Thanks for the fix! I lost my Lifx integration in WebCoRE a couple of days ago and your solution worked great for me.


Glad it worked out.