Nest thermostat mode state - no ECO


Hi, I’m not sure if this is a bug or something to do with the third-party DTH / device I’m using, so apologies in advance if I’m barking up the wrong tree.

I’m using MyNextTstat:

I’m just starting out on my webCoRE journey and I’m trying to write a piston with a condition that identifies if “thermostat mode” is set to “eco”. However, the only values I can select for “thermostat mode” are auto / cool / emergency heat / heat / off, i.e. “eco” is missing.

Within the MyNextTstat device in the ST app, I have the option to set the mode to eco, so the mode is supported.

I’ve found a workaround (Setting Nest Tstat to Eco Mode) but it would be great to be able to use thermostat mode as a condition.