Should I just start over?


So I have been having issues with webcore working properly the last month. Im not sure when it started doing what its been doing but I honestly have no clue how to resolve the issue. Some of my devices show up as placeholders, like numbers and letters. Some pistons still run but not all run correctly. I get an error message that says "There was a problem loading your devices. The date shown may be outdated; please refresh the page to try again. Any help would be greatly appreciated before I delete webcore and attempt to start over completely. Thanks


A look at my recent logs


And honestly I have no idea what this means lol Im not a programmer and or write code, I am a very novice user of webcore and smartthings. So Im just trying to find some answers on what steps I should take to try to remedy this.


Here is as hot of what one of my pistons looks like now. For some reason I lost many of my devices out of nowhere. Im not sure if it happened after an update or what.


Have you tried this? What about logging out and back in?


Unfortunately I have. Ive also logged out logged back in, changed webcore passwords, disabled all my devices, then added them back. Im just not sure what happened, because i ran webcore for almost 2 years with no problems. there was a time where i stopped messing around with it for a few months and started to notice some of my pistons werent running, and now Im stuck at this point lol


It seems like after one of the webcore updates it started happening but honestly I cant say for sure.


What hub are you using? ST? Hubitat? Have you tried rebooting it?

Maybe try creating a new instance of WC, add a few devices, and see if it sticks. Then possibly copy over some simply pistons and see if they work,


Sorry I’m using Smart things. How do I go about creating a new instance? Sorry I’m kind of a noob. Lol

  1. Open ST App

  1. Load Smart Apps

  1. Click on + (You’ll see I have two Webcore Instances already. You will see the one you currently have)

  1. Click on Webcore (Tape here to install Webcore.)

  1. You are installing a new instance, so just click Next

  1. Type a new name for this instance

  1. Go back to main menu and click on the NEW instance you have

  1. Click on Register a Browser

  1. Get 4-digit code

  1. Go to your browser and type (You will see your existing pistons there. As you can see, I already have 3 instances running.) Click on Register Instance

  1. Type in the 4-digit code. If you mess this up, you can always go back and redo it. No damage will occur.

  1. You should now see your first and second instance in the list. Select the new instance (There should be no pistons…that’s ok. We will copy some over)

  1. Now you want to copy a piston from the first instance to the new instance.

  1. Click on the line “Select the Piston you want to copy”. Select any piston from the first instance, and it will be copied to the new instance.

NOTE! Since this is a new instance, you will have to re-add your devices. However, I would select one or two important pistons, and just add the devices for those pistons and see if the new instance is working for you. If it works, then transfer all your devices and pistons over to the new instance.


Thank you so much. Can’t wait to try this out. I will let you know how it goes lol.


Ok so now i have a new problem that has come up. I made a new instance but none of my devices will load it says problem loading devices, this happens on both instances. I added all my devices in the smartapp as well. on my older instance all my devices in my older pistons now come up as just letters as numbers as its just a placeholder for something that is no longer there anymore. Any idea what could be causing this?


Interesting. The problem may be your Hubitat app. Try logging out and logging back into it.

[EDIT] Oops…ST app


Sorry I have smartthings app but i will try that.


Also, when I click the top left corner to see all my instances, its still only showing the one instance I had made a good while ago, but it did let me register a browser so i was able to get into my second instance but now its not showing the second instance.


Ok I see the new instance now but i keep getting this error.


Did logging out of/into ST help at all?

Perhaps you should try deleting the existing WC apps, and reinstalling from scratch.


No just tried logging out and back in and that didnt help. I was really hoping to find a way to fix this issue before i started over but thats what i might have to do i guess


You should back up the pistons (if possible) and get the backup codes for them.


Before you start from scratch, try to add a new device to the list of available devices. Wonder if this will jump start the discovery process.