There was a problem loading the dashboard data (August 25, 2020)


I commented out the 950 line and this got WebCore to load, but can not open any of my pistons. I just get the spinner running for ever when I click on them.

Also getting the Unable to lad your home solutions message in the Classic SmartThings App. I have not migrated and do not want to. I am getting tired of companies buying things and doing nothing but removing features and locking things out.


There are two Smartapps (webcore - line 950 and webcore pistons - line 5052-54) that you will need to update. One allows the dashboard to load, the other allows you to open pistons.


See Post 12 for a second fix that needs to be made. I didn’t spot that until some time after the first and then I edited it into the original post, so there are some references to the ‘line 950’ fix only.


Thank you so much. I had missed that one.


The Change in Webcore and Webcore piston worked beautifully… Thank you to all that worked on this… This forum has some amazing people… But i have to say that I feel so susceptible to future issues as a result of Smartthings changes… thanks again to all !!


Thanks for the workaround! I am able to access my pistons but after few seconds it kicks me out the dashboard and ask to register my browser, anyone else having the same issue?


Thanks so much, I got back in to Webcore, much appreciated!!! My lines were in Webcore: line 935
in Webcore Piston line 5046-5048


Is the fix actually editing of these lines in Webcore? Specifically changing it to what it reads in this post? If so, I’m not certain of the spacing if it requires an edit like this.


One thing I cannot find addressed in here…after you make the changes and all is well is this something that we should be circling back and undo the changes at some point in time? Are there any possible implications down the road on these changes?


I asked the same question. Apparently, we should be good:


Please see post #12. You need to comment out a line in the Webcore app and a few lines in the webcore piston app. After that republish both apps to yourself in the ide. Good luck !!


what is meant by the term “commenting out”?


Make specific coding lines ineffective (remark statements). So put 2 slashes (“//“) n front of the line. See the examples in post #12.


I’m also experiencing this issue.

Can someone handhold me through the process of actually reaching the code and editing lines? Where would i go in order to do this?

I’m ok on the concept of commenting out (seems to be a double forward slash?). Just need to know how to find and edit the code.


Followed post #12, seems pretty straight forward, (Comment out the lines, save, publish for me) still getting the dashboard error and seeing “Dashboard: Authentication failed due to an invalid token” in the logs.

What am I missing?


Orangebucket- thank you so much for this. Your hard work and insight is exceptional.


Login to IDE at and click on Smartapps


It would be pretty cool if there were any way to get a heads up from ST about changes like this before everything blows up. @orangebucket would you please submit a pull request for those changes so that we can push out a hotfix? Let me know if you are not comfortable doing that, otherwise please base changes against the master branch.


It seems like any piston that uses $shmStatus, $shmTripped, and $incidents would also fail. I think those will have to be mapped to static values since apparently SHM no longer exists in the platform.


I am seeking more information on this from SmartThings. It is unclear at this point whether the change was intentional. I want to be sure that any updates published to the webCoRE code are done correctly (i.e. is this just a temporary glitch, is there new code for STHM, is there no alternative for Groovy?)