There was a problem loading the dashboard data (August 25, 2020)


Thank you. I have no idea why i didn’t think of that.

My instance seems to be working after making the recommended edits.


Someone posted this on the ST forum in regards to SHM…

Response from Support 8/26

We are so sorry you are experiencing issues with SmartThings. This is related to an issue on our end and we are currently working hard to resolve this as soon as we can.

If you have any additional questions, or if you are actively experiencing issues once this has been resolved, don’t hesitate to reach back out and we’ll be happy to help!


Confirmed, this seems to be a temporary issue.


ST informed me that this should be fixed now, more details will be available on the ST status page soon. Would anyone who had not modified their code please give the dashboard another try now?


I just tried on unedited code, asked me for a verification code and the password. It now works.


In addition the SHM buttons have reappeared in the classic app ‘Home Solutions’ section.


Same here - thanks all


And ST finally posted on their status page

Aug 26, 2020

Issues with Smart Home Monitor in the Classic App

Resolved - Between 12:30pm EDT August 25th, 2020 to 1:55pm EDT today, August 26th, 2020, some users in the Americas may have experienced failures in loading Smart Home Monitor in the Classic app. Users may have seen Smart Home Monitor in the Classic app not trigger incidents correctly. These issues have been resolved. Please contact us via if you have any questions.
Aug 26, 14:00 EDT


How did you get the Smartthings Virtual Switch to show up in the Alexa app? The only items that show up for me when using the Alexa Routines and the “When this happens” are my ST motion sensors and locks. Is there a setting somewhere to have more device types available to Alexa Routines?


My belief is that, given SHM could be expected to remain functional until at least 14th October (not 8th September as I had previously - that is old Alexa/Goolgle sunset) and it was reported as having problems (still is), it was not intentional. The same error was experienced in Mar 2018 in the UK/EU and in May this year worldwide but cleared before any action was taking at the webCoRE end.

That said it is unclear what will happen when Classic and SHM are sunset. Given that the SHM mode is an attribute of the location, there seems no reason why that actually even needs SHM to be installed. Indeed those of us without SHM installed at all can still set and read the mode using webCoRE or ActionTiles for example. So I am not actually that worried about that. However I don’t have SHM installed and yet was still hit with this problem with location.activeIncidents. What will happen to it?

I shall submit a pull request for the hot fix as used, but I would note that the fix to webCoRE might ideally be matched with a tweak to the dashboard code where it is used (I think it is to do with the SHM icon). I also note that the fix to the webCoRE Piston could perhaps be made more elegant by returning whatever the null / empty / zero value is so $incidents would still be correct. I feel that needs a different set of eyeballs on the code. webCoRE is a little terse for me.

UPDATE: Oh no I won’t because while I was typing several new messages have arrived! I will leave the post as originally crafted though as much of it still applies.


Alexa can see Simulated Switches by default. No workaround needed.
(Just say, “Alexa, discover my devices”)


So, can the changes made as a workaround for the issue earlier today now be rolled back?


ST has identified and is working on a separate issue with IFTTT that popped up around the same time as the SHM errors. Please follow for updates

Yes, any code changes made to disable SHM incidents can now be rolled back.


Great! Thanks!


I rolled mine back and everything is working as expected.


Thanks for all of your help. I just noticed that my Echo speaks from Webcore Pistons is not working. Is that related now? I thought I read somewhere that Echo speaks for Webcore will be dropped?


I don’t think there is any connection. I don’t have any Echo devices but I’ve seen a few reports of issues with Echo Speaks today. Amazon seem to be known for moving the goalposts and I think that may have happened again.

SmartThings will be blocking access to Echo Speaks on the 8th September, if I’ve got the dates correct. It has been absolutely hammering their systems and they’ve had to pull the plug on it. The author is working on an ‘Echo Speaks Lite’ that he says will be available in time to replace it. I’ve no idea what functionality will be lost because I’ve no idea what functionality Echo Speaks has, but SmartThings seem to be be happy with what he has in mind.



Got this message a second time after reinstalling a new instance and recreating all my pistons. The new instance of webcore disappeared from by SmartApp and I seem to have lost my pistons yet again. I should have copied down my backup codes…


This also worked for me.