There was a problem loading the dashboard data (August 25, 2020)


Following steps in post #12 fixed the problem for me.
Question: Should we return webCoRE code back after regaining control?


I can confirm this solution has also worked for me too. Many thanks.


Good questions. I’m thinking until Smartthings get’s all their New App issues sorted, we should leave the changes. Hoping a real expert can reply and also let us know when we should change the Webcore Apps back to the latest Github version.


Off topic, sorry, but would you be willing to share your piston that gets the google mini to speak for you?


Hi darrenofkent… Hoping you get a reply. For the Alexa Dot, I use Smartthings and create a Virtual Switch. I then use WebCORE to write rules that will turn the Virtual Switch On or Off. I then use the Alexa App and when the Virtual Switch Triggers, Alexa say “XXXXX”.


This is just silly, updated IDE and back up and running now.


The code tweaks prevent errors occurring when SHM active incidents are accessed. If you’d miss having that information available then you’d want to revert the code , assuming whatever ST did today wasn’t intentional and is also reverted. However there is only a couple of weeks before SHM is turned off as it requires the Classic app. At that point things might break again anyway.

Otherwise I wouldn’t be in any rush. Changes might be desirable anyway to lose SHM and Routines, though technically SHM modes would still be usable without SHM being installed (a bit pointless possibly, but usable).


I was having this same problem (like everyone else has reported so far), but then did a search for “incidents” in the code of the main WebCore app, commented out the line, and then was able to login and see my dashboard like always. Thanks for this info!!!


I cannot take credit for this one…
@orangebucket was the “Super-Sleuth”. pipe

All I did was test it, and report back…

I didn’t mention it before, but to edit a piston, I also had to comment out 3 lines in the “Piston” file.


On a side note, I kind of hope SmartThings sees these numbers…
In less than ten hours, nearly 600 views on this one topic…

(and probably near a thousand views, if we count the duplicate topics)


I notice that the SHM section says this in the classic app. Showed the old SHM yesterday. I wonder if this was related to our troubles today.


I have same problem: physicalgraph.api.StatusCodeException: Invalid http status code returned: 401 @line 950 (api_get_base_result)

I also the “Unable to load your Home Solutions.” in place of SHM in classic app. I have not migrated over to the new app, however, I do have the message that its available for migration in the top banner on classic app.


After comment out as line 950 and 5052-5054, I can access successfully, but all my pistons are gone, but it can be seen in IDE smartapp list. Can some someone please give me instruction to transfer the piston from IDE to dashboard for edit again, many thanks.
P.S. I already tried “clean up and rebuild data cache” in ST app, but no success.


This workaround also work for me for now (GRClark link on upper right side)


Suggested workaround also worked for me.


I was just looking for a thread where this issue was encountered in the UK in about March 2018.

Instead I found we had this issue in May this year …


Same thing for me here in Australia. Thanks for the workaround, much needed so I can backup my pistons… phew!


One more happy camper… now. :wink:

Thanks for the work-around.


Hi All,

I did this work around this Am-- still getting the dashboard error. Any other tips?

Thank you



… for whatever reason my first save, publish did not stick. repeated and now working. best E