There was a problem loading the dashboard data.... Unable to load webcore dashboard


I had to have Smarthings support remove a weird duplicate owner (old email that was a smarthings account) from my account. Now when I try to login to webcore I get the following error at the top of the webcore dashboard: “There was a problem loading the dashboard data… The data shown below may be outdated; please log out if this problem persists.”

I don’t see any pistons in webcore. I contacted smarthings support again and they said:
“As you are unable to login to Webcore I request you to contact Webcore support. Our scope of is to only link the Webcore smart app to SmartThings. However, I request you to once give a try by un-linking and re-linking the Webcore in IDE.”

I don’t know how to unlink and relink webcore in the IDE. Can someone help me?

What I have tried:

  1. Smarthings classic app wecore smartapp: security, changed dashboard password.
  2. Smarthings classic app wecore smartapp: Clean up and rebuild data cache
  3. Updated webcore in IDE (it was up to date already)

I really don’t want to lose my pistons. I do have them backed up but do not have their 4 digit codes saved.

I have read these topics to no avail:


Tagging @ipaterson


I’ll PM you with more info tomorrow. Do you still see your pistons at > my locations > smartapps?




It sounds like this case. webCoRE is still installed and pistons are still there but the dashboard can’t communicate with the smart apps.

To make sure that is the correct solution and to get the information needed to make it work, please open the error console in your browser while viewing the webCoRE dashboard and look for an error. Your error console should show a web request error trying to connect to your SmartThings account containing /api/token/YOUR-TOKEN/smartapps/ with your [seemingly expired] token.

If you see an error like that, post the first few characters of that token or just modify the example code linked above, substituting your own token. That code will cause your webCoRE smart app to generate a new token that should allow the dashboard to communicate with SmartThings again.


I am not 100% sure I know what you mean so this is what I tried:
I first went into Postman and sent a “post” to few digits of token here*/smartapps/installations/othernumbershere*/intf/dashboard/load?token=&dashboard=0&dev=0&callback=angular.callbacks._1

That resulted in
“error”: “invalid_token”,
“error_description”: “*first few digits of token

The first few digits of token was the actual token I just removed in this community posting for security.

I tried to re-login to the dashboard and got the same error as before.

I then modified my webcore code as you described in the linked posting and still same issue. Am I doing this correctly?


The first set of numbers and letters, which is your token, is the one that we want to change. The code in the linked topic will replace that token with a new one the next time you open webCoRE in the ST mobile app.

So, you can follow the instructions in the linked topic, but just replace 0a18ba22 here with the first few letters of your actual token. This code tweak will allow the current token to be changed, then if you’re able to log in to the dashboard again you can safely revert back to the original code or just wait for the next webCoRE update to overwrite the changes.

private initializeWebCoREEndpoint() {
    try {
        if (!state.endpoint || state.endpoint.startsWith('0a18ba22')) {


So I am still getting the same error when I reload the smartapp on my phone with the new code, register and load the dashboard. But I noticed that now in the error console when I load the dashboard I get this:
GET net::ERR_ABORTED 500 (Internal Server Error)


That error should correspond to one in the ST logs at > Live Logging. You should see an error pop up each time you refresh the dashboard. That error message will have more info to figure out what’s wrong.

To confirm, is that token in the dashboard error URL different now than the old one?


I cannot get to Is this site down? I can however get to --> Live Logging.

Note that the live logging at graph.api… is not giving any webcore related error messages as I try to login.

In the debug console on the when I load the dashboard the old token (that I truncated) is still being sent in the get command. Therefore I assume the token is not being refreshed.

In other news…Smarthings support suggested that I do this:
" I request you to log into IDE and then select My SmartApps or My Device Handlers there you will find the Webcore from there you can unlink it successfully."

Won’t that wipe out my pistons?


https not http


typo…Yes https just redirects to the which is not throwing any related errors in the log.


not for everyone :slight_smile: it redirects users to their specific SHARD


Tagging @ipaterson

BTW Thank you so much fro your help!!!


I fixed it!!!
I was using your first code that said startswith instead of contains. Also I had tried to change my webcore password in my smarthings app and I reverted back to the original password. Once I did that when I reloaded the dashboard it prompted me for the webcore password, I entered the original one and I was in! Thanks for your help!


Ah! Sorry about that, I updated the original post in case I reference it again. Glad you’re back in action.


I have the same problem.

I modified the Smartapp code at line 841, saved, published, closed Webcore, registered browser, logged in. Same error.


Make sure you use the contains not starts with code


@xraycat, the error from your ST Logs suggests that the webCoRE Storage app may be outdated. Please see this thread plus the additional details in my Dec 19 reply for identifying whether your app is outdated.

To future readers, please heed the warning in the linked task. This is an exceptional case and not a normal cause of the There was a problem loading the dashboard data. The data shown below may be outdated; please log out if this problem persists message. Please search for other solutions and do not attempt this workaround unless instructed to do so.