webCORE Dashboard Completely Broken. Please Help [UndeclaredThrowableException]


And this morning the Things list is broken again for me. Interestingly, the webCoRE dashboard is still loading.


I wonder if this is somehow related to building out the list of devices rather than fetching the list of devices… Admittedly I’m not very familiar with how all of that works but perhaps if webCoRE caches the devices on a “good day” it will continue to work and on a “bad day” it will continue to fail regardless of then-current platform performance.

I believe that the device data can be refreshed without actually adding or removing any devices. ST app > Automation > webCoRE > Settings > Available devices > Available devices > Done > Back > Done.

With the consideration that this could be related to platform performance at a point in the past rather than an ever-present issue, would a few others please try the steps above to periodically (i.e. if it doesn’t work try again a few hours or days later) reset those devices? No guarantees of course that this will work but @Nezmo’s observation suggests that this is worth trying.


I did try this when my dashboard was still not loading (and before I added a physical new device). It did not seem to help when I tried it.


Is there a way I can remove webcore without loosing my pistons? Being stuck between “nothing we can do to help” and “we dont support webcore” is a very frustrating place to be and I am in need of some work around to edit my pistons.


If you capture the import code from each pison, you can get each one back with that code if anything happens to any of them


This code is available for each piston for which backup was enabled at account.smartthings.com > My Locations > Smartapps. Click a piston then copy the “bin” code shown in the popup.

However I strongly recommend also copying the chunks data, name, and category for each piston. The chunk data can be used for a restore if necessary (PM me and I will convert them into a backup file that you can import). The bin codes reference piston data that is encrypted based on your ST account. If you have switched over to a Samsung account you will only have access to the backup bins for pistons edited after that switch. The bin codes do not change but saving a piston saves a new encrypted copy for your new account. Recording the chunk data provides a safety net in case the backup codes fail.

Note that this is not general advice… Anyone who can access the dashboard should use the export feature to save backup copies of their pistons. It’s not worth the effort to copy the chunks out of the IDE since you get the same data in a much more convenient backup file.


Thank You. I took a few screen shots to ensure I am saving the data you are suggesting. Can you confirm I am after the right data.

Also I did make a backup of my pistons a few months ago but I have no idea what the file name / format / extension was and I am having a hard time locating it. Can you give me a a hint of what to look for before I go and collect all of these bin codes and such.


Those are correct. Some pistons will have chunk:1 chunk:2 etc. so copy the entire line including the chunk:* label, text label, and data for each.

Avoid anything fancy like double clicking to select the chunk data because some have characters like + that would cause only a portion of the code to be copied. Select each line with a click and drag as shown below:


The backup filename is webCoRE followed by the date and a .backup extension.

While you’re in the smartapps list, also copy some data from the webCoRE app itself in the same way. In the Application State table find the settings row which will look something like {categories=[{i=5, n=Weather, t=d}, {i=1, n=Security, t=d}, {i=3, n=Energy, t=dt}, ... as well as the vars row. These global settings cannot be restored from a backup file yet, but they are human-readable enough for you to be able to reconfigure your settings on a new instance. For example, create categories in the same order on the new instance so that your pistons map to the same (since the backup file only includes that ID number for the category of each piston as shown in your screenshot). Create variables with the same name and type.


I have been dead in the water as well. Started rebuilding in another instance but good to know that I can find the backup code in the IDE.

Funny thing is, my Things tab started working again in ST and my Dashboard was loading as well. I thought the issue was resolved. Went to add more devices and all was well. Went to make some changes in webCoRE and had to re-select some devices I previously un-selected trying to get webCoRE Dashboard to load. Somewhere, somehow, my Dashboard stopped working again but the Things tab still works.


Happy Thanksgiving! Today I intended to spend some time rebuilding my WebCORE. For giggles I tried launching a dashboard session from my phone which previously had not worked. Amazingly it started working from my iphone! I was able to open a browser session and I could open my pistons. When the dashboard initially loaded I noticed a message that a “database” has been upgraded.

I then tried from my PC in a chrome browser and I got the same error message and was stuck on the same “\loading” message.

I then went back in to edit my pistons on my iphone and it worked fine.

Net something with WebCore is not letting the dashboard load in Chrome. Perhaps this database upgrade?? Happy I could finally edit my pistons, but doing it on a phone is a pain.

I think the fact that I am able to edit pistons in the Safari browser on my iphone and not in Chrome on a PC rules this out as being a Smartthings problem.


or perhaps an extension in Chrome? try disabling ones that may block content. if that resolves the issue, you should be able to create an exemption and re-enable the extension.


No luck on the Chrome Extensions. I turned them all off, cleared cache and local storage and got the same error.

I also tried MSIE on my PC and got the same error.

I then tried Chrome from my iphone and also got the same error.

Back to Safari on my iphone and it works fine.

I will also add that for every browser this fails on I need to register my browser for each attempt. It never seems to fully register.


Based on what we’ve seen so far this is highly related to timing rather than browser. Just keep trying periodically, the easiest way to kill everything and start a new login is with Incognito mode in Chrome.


FYI I tried opening the dashboard in an incognito window and Chrome both on my iphone and PC. Both give the same timeout error.

In my humble opinion whatever database upgrade that ran on Safari is not running on Chrome or MSIE causing the dashboard not to load.


I am having these issues as well now

i can log into a 2nd instance of webcore but none of my pistons are in it (was previously using it for icons and presence sensors i believe)

I did try logging into webcore via safari, no luck for me there either

UPDATE took several attempts in smartthings app to delete devices that were accessible to webcore. when i deleted them, it would say there was an error. but when i went back in to do it again, i noticed that it saved ‘some’ of the updates i had made. so i just kept going back in there and updating it until they were all updated. (most of the devices i deleted were all of my ‘Echo Speaks’ devices and some wall plugs that i was trying to add for xmas lights)

i can now log back into webcore (fingers crossed). i tried to look and see how many devices it could actually access, but i dont know where to look for that info at in webcore?


The quickest way to count the devices associated with webCoRE, assuming you can access the dashboard, is to use the following command in the browser’s developer console which just displays the total number of authorized devices: scope.devices.length.





He meant in your browser, like in Chrome, hit F12, you’ll see Console up top.


I’m down to 106 devices now


I am back to fully broken. It was working in Safari on my iphone, now that is not working anymore.

I am willing to help anyone debug this.