webCORE Dashboard Completely Broken. Please Help [UndeclaredThrowableException]


#112

Thanks, good to know. This problem seems to come and go depending on perhaps the load of the SmartThings platform at the time you load the dashboard or any other mystery factors. It is good to know that you were able to resolve it by reducing the number of devices. For many that is not an option and not all who have tried it have been successful.

SmartThings support has heard from a growing number of people affected by this, but now going on 3 or 4 months it seems unlikely to be resolved with any urgency. I’ve tried several times to get ady to take a look at this in case there is something that could be done differently to work with devices in webCoRE, but as far as I can see whether the devices will load or not is at the whim of the platform.

An option that may be helpful depending on what you need to do with the dashboard is to skip the loading of devices entirely. If the dashboard loads you would not be able to select devices for adding/editing pistons and devices in existing pistons would appear as the raw device ID rather than name, but you would be able to do some device-agnostic edits, see your pistons and tiles, and export your pistons to a backup file. I cannot recommend that anyone actually does this and will not post the code publicly because running webCoRE without the device data is untested and it would probably be quite easy to make the situation worse.


#113

i was going to try to add a few devices back into webcore to see if i could hit a hard number of devices where it cut me off, but now I’m not able to make my changes stick in the smartthings app when selecting the webcore devices that i want. Sometimes it’s throwing an error when i try to save the changes, sometimes it’s not. doesn’t seem to be any type of pattern of when the error message pops up, but either way its not saving my changes…

not sure if its relevant, but i have been able to log into webcore (from all devices) with no problems since i dumped about 50 devices earlier today. but i do still occasionally get the warning about the database (i forget what it said exactly…)


#114

EDIT: My issue may be that I have two locations in my account post-ST to Samsung account migration. Both locations are marked DEFAULT. I’ve contacted ST support to get them to delete out the other empty location. Maybe that will fix it.

Count me as another person that can’t get into my dashboard at all. I have been trying for 7 days, on 3 different devices, on 3 different internet connections/networks, at completely different times of day.

Every time I get the “there was a problem loading the dashboard data” error mentioned above.

I’ve tried both adding and removing devices to webcore from ST (I only have ~10 right now), but that didn’t help / change anything.

I tried from 5 different browsers, including incognito/private mode, but that didn’t help / change anything.

Is there ANYTHING I can do to at least get a COPY of my piston code??? I have no idea if they were configured to backup or not, and obviously can’t verify since I can’t get in my darn dashboard.


#115

This thread is for a very specific cause of that message, can you please confirm any errors that you see in account.smartthings.com > Live Logging corresponding to each dashboard refresh?


#116

After submitting the support request to fix the duplicate location, it is working again (or at least it did a minute ago). So it was likely on their end. Sorry for the noise/confusion.


#117

The response I got from smartthings support…

Thanks for getting in touch, apologies for the trouble that you’re running into here.

It does appear that you have two locations, and it looks like the unused location is hitting a bug that won’t let it be deleted. It is something we are aware of and are working on fixing, so keep an eye out for that to be corrected down the road.

With that in mind, it sounds like the extra location may also be causing some confusion in the app as it being pulled up would make it look like there are no devices loading in the app. To confirm that you are looking at the right Location,

  1. Tap Menu Menu
  2. Tap the Down Arrow Down Arrow
  3. Tap on the Location you originally set for your Hub.
  4. Navigating to My Home My Home then Things, and look for your devices there.

Let me know if that doesn’t get you going again and I’d be happy to assist further!

All the best,

Tony
SmartThings Support


#118

Try cleaning up and rebuilding data cache in webCoRE (ST Classic app, open webCoRE and go to Settings)

Also, if you can provide me with something that can help me locate your account, I can look up the server side logs and figure out what the problem is. The fact that less devices work points to a possible state over limit, there’s a 100,000 bytes limit. Did you install the webCoRE Storage app? That one eases up things on many devices situations.


#123

I’ve released a dirty fix for the timeouts.

v0.3.109.20181207 - BETA M3 - Dirty fix for dashboard timeouts: seems like ST has a lot of trouble reading the list of devices/commands/attributes/values these days, so giving up on reading values makes this much faster - temporarily?!

The problem is the ST platform timing out (there’s an execution limit of 20s) while reading the list of devices - we’re reading all selected devices with their commands, attributes, and values - I gave up on the values since they’re not really used outside of the right hand side panel in the piston editor - expect to see NaN (not a number) in lots of places there - this will not affect anything else other than just that panel - I haven’t made changes to it in hopes of being able to revert this change at a later time.

Sorry it took me so long,
Adrian


Change announcement for 3.109?
#127

@andyhawks @cben0ist @emiller233 @JasonJoel @jasonrwise77 @jkp @John_DellArciprete @lflorack @Nezmo @rontalley @whoismoses @wjarrettc @wjwong54 @Yairsmail

@ady624 has found and released a workaround that may resolve this for most of you until SmartThings is able to address the platform issues. Please update to the latest version of webCoRE and let us know how it’s working for you.

Check ady’s reply above for more details, this change disables display of current device attribute values in the right column of the piston editor.

47%20AM


#128

I will update but note I have been back operational for some weeks now.


#129

I’ve updated, but as previously noted, I am now running three instances of WebCoRE as a workaround. Over the holidays, I can tinker around with merging them back together to see how it holds up.


#130

I updated to the latest version. Tried several browsers, chrome, incognito, safari… still not loading. Safari was working for me a few weeks ago when chrome was not.

I also cleared cache as suggested above.


#131

Do you have any logs in the IDE? Something about how long it took?


#132

@ady624 @ipaterson Just did a quick test on the new version. Created a brand new instance of WebCoRE and threw the kitchen sink at it (just over 200 devices). The first time I tried to load the dashboard, I got the timeout error, but then I switched to another instance and came back to the new test one and it loaded properly. It looks like it may still be susceptible to the timeout issue but this change must have greatly reduced the chance of hitting it (previously, my maximum number of devices was somewhere in the 50-70 range depending on when I would try it).


#133

Here are the logs specific to webcore

Logs

Clear

d759ecfa-1d61-4c22-ae4d-51b54cc1acf5 4:00:05 PM: error java.lang.reflect.UndeclaredThrowableException @line 1700 (listAvailableDevices)

d759ecfa-1d61-4c22-ae4d-51b54cc1acf5 3:59:45 PM: error Dashboard: Authentication failed due to an invalid token

d759ecfa-1d61-4c22-ae4d-51b54cc1acf5 3:59:39 PM: error Dashboard: Authentication failed due to an invalid token

d759ecfa-1d61-4c22-ae4d-51b54cc1acf5 3:59:07 PM: debug getChildDevices(false), children=0


#134

@ipaterson @ady624 I am still getting the same weird info warnings.


#135

Has anyone successfully transitioned from errors preventing dashboard access to no errors following the latest update?


#136

I have not.