webCORE Dashboard Completely Broken. Please Help [UndeclaredThrowableException]


Has there been any progress on this? I have no way of accessing the dashboard and I am not sure of what my next steps should be.

I have a lot of hours in the pistons and I hate to give up.


I am currently have the same issues…

I did find that Internet Explorer browser works sometimes and also the app on my Ipad works 100%. I only have issues with Google Chrome. IE will also crash a lot…


What errors do you see in Live Logging at account.smartthings.com when you try to refresh the dashboard?


I have finally been able to get the dashboard to load. @ipaterson advice I removed all of my devices from the webcore smartapp. I then systematically added them back to see when it would break.

I did find that anytime I added my Ecobee thermostats it would not load. I have 3 Ecobees. I also had problems when I added my Amazon Echo devices.

I am not sure if it was the sum total of devices that broke it or the Echos and Echobees themselves but I thought I would pass that along for anyone who wants to try and troubleshoot their own dashboard.


The echos and ecobees may each have a very large number of attributes, it’s definitely possible that those specific devices take abnormally long to load. @ady624 mentioned this peculiarity of Echo devices to me in the past.

Please export a backup of your pistons ASAP since you can finally access the dashboard. Just in case!

To anyone else who tries this, be very very careful if you edit any pistons while devices are removed. All of your piston code will show device IDs rather than names but if you edit the statements it will not be possible to reselect those now-unknown devices. I’m not sure but this could also break devices within expressions if a piston is re-saved without access to the devices that it needs.


So i ran the Live Logging, as soon as it ran it fixed the issue??

Not sure how that happened but its working now.


76ff715c-1ea4-4146-ad12-960f878d34a1 2:40:14 PM: debug getChildDevices(false), children=0

76ff715c-1ea4-4146-ad12-960f878d34a1 2:40:13 PM: error Dashboard: Authentication failed due to an invalid token

76ff715c-1ea4-4146-ad12-960f878d34a1 2:40:08 PM: error Dashboard: Authentication failed due to an invalid PIN

76ff715c-1ea4-4146-ad12-960f878d34a1 2:40:08 PM: error Dashboard: Authentication failed due to an invalid token

e528374c-5641-44f7-afdb-efb7485bf234 2:40:02 PM: info postEventToEndpoint: event successfully posted.

e528374c-5641-44f7-afdb-efb7485bf234 2:40:02 PM: debug Property Change Event temperature: 67 (source: DEVICE)

3e553488-a218-4b12-aa80-109c7314c967 2:40:02 PM: debug sending data to AT

3e553488-a218-4b12-aa80-109c7314c967 2:40:02 PM: debug A sensor event occurred: [name:temperature, deviceId:4d11750d-3713-4b7c-a159-67961e6a7c3f, isoDate:2018-12-29T20:40:00.097Z, unit:F, value:67]

76ff715c-1ea4-4146-ad12-960f878d34a1 2:40:01 PM: error Dashboard: Authentication failed due to an invalid token

2:39:32 PM: info Waiting on events…

2:39:32 PM: info For past logs for individual things go to the My Devices section, find the device and click on the Events link on the device information page.

2:39:32 PM: info This console provides live logging of your SmartThings.


That does sound like it could be this specific bug. Whether it errors out depends on how quickly SmartThings loads your device info, so sometimes it will work and sometimes it won’t based on the platform load. You can read backward through this thread for more advice if it recurs.


This just happened to me today. Was working fine last night.

0547d58a-7938-40c5-809b-5387495cf6ba 10:33:19 PM:errorjava.lang.reflect.UndeclaredThrowableException @line 1700 (listAvailableDevices)

0547d58a-7938-40c5-809b-5387495cf6ba 10:32:58 PM:error Dashboard: Authentication failed due to an invalid token

0547d58a-7938-40c5-809b-5387495cf6ba 10:32:54 PM:error Dashboard: Authentication failed due to an invalid token


Those are the same logs I was getting.


Not seeing any fix or the reason why the token is expiring. Tried on tablet and phone and the webcore app


I am on that beta but still no luck

public static String version() { return “v0.3.109.20181207” }

  • 12/07/2018 >>> v0.3.109.20181207 - BETA M3 - Dirty fix for dashboard


I can confirm. Looks like timeout on devices with many properties (echos and ecobees). Started getting this issue after added 2 ecobees and 7 echoes (~100 devices in total).

Keeping only the devices needed for the pistons helped, but I wish I could have all of them in my disposal in webCORE.

Problem loading the dashboard data

I’ve had that same issue. It was like a slow process with the issue moving from one browser and PC to the next until after 2 days I could not access my webcore dashboard any more.
Thanks to the pointer here I removed some of my Echo devices from the webcore configuration and I could access the dashboard again.
I still would be nice to have all my Echo devices in webcore. Is there any chance for a permanent fix for this issue?


Just had the same issue here, also fixed by removing some echo devices. Thanks all for this thread.


Chalk another person up with this error. Caused by 2 Ecobee thermostats created via Ecobee Suite manager.


This just happened to me today.

System / App: Smart Things Classic User
Devices in ST: ~130 (before problems)

What changed:

  • Added “Echo Speaks” SmartApp to SmartThings
  • Added ~10 echo devices into WebCore speaker section to allow use by this smartapp.

Webcore wouldn’t load.

What fixed it:

  • Removed 10 new devices from WebCore, back to normal.


I have the same problem. Removing devices has fixed it temporarily.


Oh thank you! Removed a few echo devices and my pistons can be opened again


not sure if this related or not?

so i created a 2nd instance of webcore, just for all of my echos/pistons per Ady’s advse after i first had this issue. worked well for months. now I haven’t been able to log into this instance for a couple weeks now. i hadn’t changed anything either to cause it. how to i get back into it?

i tried doing a cleanup for the instance inside of smartthings. it failed

if i open the dashboard directly from smartthings, it asks me for my password, type it in, but then it takes me back to my original instance of webcore (wrong one)

not sure where to even troubleshoot this one at?


this is the error i get:
java.lang.reflect.UndeclaredThrowableException @line 1701 (listAvailableDevices)