webCORE Dashboard Completely Broken. Please Help [UndeclaredThrowableException]


#159

Has there been a solution yet to correct the “NaN” problem?
I’m running the latest version (v0.3.10a) and this issue is still occurring for me.
All the searches I have done point me to this thread and one other one, but neither seem to have a solution.


#160

No, it has not been addressed. My guess is it won’t be.


#161

It is caused by a fix that ady attempted, but since it does not seem that anyone previously experiencing this error found relief with that change in place it will be reverted back to normal in the next release.


#162

I’m glad to be wrong.


#163

Hi, my dashboard is somewhat broken since a few days ago, I’m pretty sure it worked last week. What happens is that top left button group becomes blank, no longer shows the icon, and the dropdown menu doesn’t have checkmarks when selected, also drag-drop line segements no longer works after the “allowing moving of items” button is active as you can see in the screenshot it’s been highlighted to blue. This is not as severe as other people, but I’m new to Smartthings and Webcore (started two weeks ago), and it really bugs me and I don’t know where is best place to ask question for this. I’ve also been searching for similar symptoms online, but couldn’t find anything related. If anyone can tell me how to troubleshoot this or push me to the right direction, will really appreciate!

Capture Capture2


No icons in the dashboard
#164

Try opening the ST Classic app, go to Automation > your instance of webcore > Settings > rebuild and clean up data cache

Also, perform a refresh on your browser


#165

Thank you for your quick reply, just did that, and then refreshed the browser, same issue still. To double make sure it’s not the cache in my browser, I used incognito of Chrome, didn’t work there either. BTW, it’s not only happening in Chrome, I tried Firefox and mobile Chrome, didn’t work there either.


#166

Thanks for reporting, but this in needs to be in a separate thread. The one you posted in is not related to missing icons.


#167

It has missing icons as you can see from the screenshot, but if there is another thread that is more related to my question, I’d like to try there too. I don’t know where that thread is though.


#168

Add me to the list of users impacted by this issue. I have 4 ecobee thermostats. When I used Smartthings default handler, I was able to add them to Webcore. But I needed to control the program, so I switched to Ecobee Suite handler, and now I am only able to add 3 ecobee thermostats to Webcore. If I add the 4th one, I get the listAvailableDevices timeout described above.

Live log with 3 ecobee thermostats:

4:17:42 PM: debug getChildDevices(false), children=0
4:17:42 PM: debug Generated list of devices in 16237ms. Data size is 29560
4:17:37 PM: debug getChildDevices(false), children=0
4:17:37 PM: debug Generated list of devices in 15867ms. Data size is 29560

But with 4 ecobee thermostats:

4:24:27 PM: error java.lang.reflect.UndeclaredThrowableException @line 1712 (listAvailableDevices)

Is the issue that the API call is timing out on ST side? Or is the Webcore Suite device handler taking too long?


#169

Have you tried the update mentioned here…


#170

This morning, I removed Webcore and reinstalled it fresh. The version I tested with is v0.3.10c.20190522.


#171

Same thing I get when I add too many Echo Speaks devices. I still can’t add more than a few (number varies) without getting the dashboard load errors. I’ve tried all updates/suggestions.