Webcore not receiving some (most) trigger events


Starting yesterday around 4PM eastern and continuing through today most motion events are not getting to webcore.

All the motion events are showing up in the ST history on the app and website.

I’ve tried using the dev branch and resetting the token, I’ve tried repairing the install, I’ve tried pausing and unpausing pistons.

Any help would be appreciated.


It is always possible that ST has made some change on the backend that is causing the issue. It could be limited to a particular SHARD or may be affecting everyone. You may want to post the following info:

SHARD you are on… when you login to IDE at https://account.SmartThings.com … what is listed near the beginning of the url you are redirected to … NA02, EU, AP, etc?
Brand/model of the sensors and are you using a custom device handler or a ST stock device handler?


When I got to that site it just takes me directly to the ide “graph.”

As for the device handler, it seems to be affecting different motion detectors that are using the same handler differently.

For instance, one started working again on its own but another of the same type that worked earlier stopped working after.

I’m not using any built in device handlers for motion detectors.

Another weird thing that’s happening is if I “test” a piston after they count down they start counting up. Some pistons are working just fine mind you. I have made no changes to any piston in months, so something is going on with ST or WC. :frowning:


Just a small observation…

Normally, a piston with a motion sensor as a trigger will not display a countdown on the Dashboard.
(That is usually seen on timers or WAITs)

Side Note:

When Motion Sensors start becoming unreliable, changing the battery is likely the first step.


So just to update this with more troubleshooting. I have a motion event being triggered in one piston but not another. So I’m pretty sure it’s a webcore problem.

Regarding the timers, that’s the piston waiting to see if motion is stopped to then turn off the light.


This is good. It means the sensor reported the status to the hub.


Is this two sensors? or the same sensor in two pistons?


It’s the same sensor in two pistons.

The timers are counting down as normal when I do a test, then when they hit zero they go to “pending” then start counting up. So no this is not “good” or “normal”.


Doesn’t work anymore.

Still works.

You can see these haven’t been modified in years.


The general advice for SmartThings is:
When an event comes in, only a single piston should execute.

If you have multiple pistons with the exact same trigger, then oftentimes, some of them will get lost in all the commotion.

Notice how Sensor 12 going active (or inactive) will try to execute BOTH pistons?

With regards to this… The timers counting on the Dashboard is drawn by HTML coding… So a bug in your web browser display does NOT mean the piston is not working. (Ctrl-F5 will refresh the Dashboard display)

My guess is Sensor 4 or Sensor 12 needs new batteries…


Also, be aware that in your “working” piston, the following command does not work:


It is incomplete code, and essentially fires 3 min after the event…
(Regardless if there is a change or not)


So explain to me why after several years of working it suddenly stopped working without me touching it.

You’re not being helpful, @WCmore

If you can’t help you can stop responding.


Everything I said was authentic… No need to get a bad attitude.


Low batteries is the most obvious answer.


Dude, it’s not a bad attitude. I’m frustrated because something that worked for two years stopped working with no changes from me. You’re criticizing my code, which works fine. I just asked you stop responding because it’s not helping.

I don’t have LOW BATTERIES. The events are showing up in ST logs in real time.


I understand your frustration. I really do.
At times, SmartThings is really testing my patience…

For the record, I was NOT criticizing your code…
I was only clarifying that multiple pistons running on the same trigger has never been 100% reliable!

… and how the countdown has nothing to do with the actual action…

… and pointing out that
is broken code… Unfinished… Does not work… Never has worked.

It is not your fault… It was just new, experimental code that ady was working on when SmartThings recruited him. It was never completed, nor removed.

Now, this cannot stop you from using it… but keep in mind that that trigger is the same as:

IF Sensor6's contact changes (to anything), then WAIT 3 min, and continue

It does NOT check to see it is “stays unchanged”.


Fair enough and thanks for letting me know about that one thing.

I wasn’t posting these two pistons because of that not working though.

Pistons that don’t share triggers aren’t firing either. I just thought it was odd that this event was triggering consistently on one piston and not on the other.


Also, regarding the timers “counting up” it’s only on the ones that aren’t working so it just seemed like it could be related.


I apologize if I sometimes come off a bit forward…

I have created / worked on tens of thousands of pistons over the years, and I try to summarize past experiences here so others will not have the same troubles as I have had, LOL.

All that being said, it could very well be a SmartThings update (behind-the-scenes) that is causing this… but if not, then the various recommendations I gave on this page are all good advice.


I appreciate that. I may not be active here but I’ve been using and following webcore for years and years. I just never bothered making an account because I didn’t really have a problem that I couldn’t solve. I only made this account because I couldn’t find anyone else here having the same problem.


I am usually the eternal optimist, but when it comes to SmartThings… I suspect that things will get worse before they get better…

… Especially over the next few months.