Another "There was a problem loading the dashboard data" error



Good that Brad_ST confirmed your issue on the ST forum :slight_smile:


Not sure he has. No response yet. And I just got the canned reply from ST Support that they can’t help as webCoRE is unsupported.

In other words, this is going nowhere right now.


That’s weird. He must have deleted his post. He did say it matched to the issue in that post.


Ok, he posted again

But now, it is not the same issue.


The token error I showed above sounds like a webCoRE issue to me.


Why the LOL? I’m not exactly the only person running Echo Speaks and using webCoRE.

Say that is the issue. What then?


So you were right. Removing the Echo devices from available devices in WC has resolved the dashboard problem.

But that’s not the problem resolved. Others are using Echo Speaks and WC so there does seem to be an actual issue. I’m wondering if I just hit an issue with total number of devices causing a timeout or something.

But why a token issue?


I have 5 loaded into WC and haven’t run into any issues yet. crossing fingers.



OK, Now I’m freaked out. Because my Dashboard returned on my Home Hub two days ago after I had changed the Location name of one of my hubs and deleted a suspicious piston, I tried doing that again. But instead of deleting only the suspicious piston, I also deleted a few other unused (test) pistons. (I did this via the Samsung IDE).
Next step was to re-register a browser, but when I went into the phone app of the Home Hub, the webCore smartapp has disappeared!
Going back to the Samsung IDE, webCore and the pistons have also disappeared from the IDE. On the other two hubs, webCore and all pistons seem to still be there.
Please, please tell me there is a way to fix this! This feels like a nightmare and I hope someone like @ipaterson would be able to wake me up. :disappointed_relieved:
Thanks guys.
Edit: I thought of re-adding the webCore app, but that will most certainly not bring all the pistons (more than 80 of them) back and it may destroy any existing/remaining links which could perhaps have been used by the minions at webCore’s to get things back to normal.


Thanks Ian. I’m aware of that thread. Nothing in there talks to the issue I am having with Echo Speaks devices though. I have posted in the Echo Speaks thread in the ST community.


That sounds like a bad situation, please post a new topic to see if anyone else has deleted pistons outside of webCoRE and experienced a similar problem.


So can anyone help with my issue? Totally repeatable. Just tried again. Add one or many Echo Speaks devices and dashboard will not load. Error message here:


As I have a backup of my pistons, I re-installed the SmartApp on my mobile and started to import my pistons. It is an unbelievably slow process, but at least, I have the backups. (The pistons have to be imported one by one and it takes something like 2 minutes to load the list of pistons from the backup file.)
After importing about four piston (some pistons don’t import the contents the first time and have to be deleted and important a second time before the contents of the piston comes through) the “There was a problem loading dashboard data” error reared its head again.
All of the symptoms are back.
I stayed away from the troublesome piston and have not tried to import it.
(I did all automation in webCore to keep things simple, so I have no automation now. Makes one realize how many automation has been added through the years.)
Any suggestions? By the way, I have been running Echo Speaks for some time without issues and can’t imagine being without it again. I very much doubt that that is my problem, since the current issue appeared when a piston would not save.
Any suggestions would be greatly appreciated.


When you add, which group do you put the ES device in? Speech synthesizers or music players? Probably have nothing to do with the issue but just curious.


What happens if you try to add one or more to a new instance of webcore?


I’ve tried various options. At first any group it showed up in. Last try yesterday was one device in sensor only. It’s my understanding you only really need to add to one category anyway (although I usually add to all).

I did some more testing. Starting with adding all 10 Echo devices to ‘Sensors’ and then taking one out at a time. I get to 6 devices left and the dashboard will load. Yet yesterday just one Echo device would stop the dashboard loading. I have tried adding a different 7th device and boom, dashboard won’t load. This is starting to look like some kind of time out issue.


Dashboard loads fine with all 10 Echo devices included in webCoRE.


New error in live logging while I go from 6 to 7 Echo devices:

java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds: 11423452077275 @line -1 (doCall)

And now with just 6 Echo devices dashboard not loading again and throwing prior error.


Which shard are you on? I think I’m on the original ones still. Haven’t migrated my account either, waiting for it to explode I guess.