Did Restore a piston using a backup code change today?



I noticed today when I add a piston and choose Restore a piston using a backup code that I am no longer presented with the pull down list of devices to select devices. Instead I am presented with a search field that does not work. I must say, I do not like this new feature. Please consider bringing back the pull down list. :slight_smile:


Have you tried it again? It is working here


I tried about 10 minutes ago but still nothing. I have tried rebuilding my cache. I have tried different browsers. I guess it doesn’t like me any more. :slight_smile:


Ok so just going to check all my bases, you do have at least one RGB bulb correct?


I have 20


What restore code are you trying to use?


Here is one.

And this one


@ipaterson and/or @ady624

When trying to restore a piston that has RGB bulbs there is no longer a populated list of devices. As you can see below.

Switch is populating correctly and even displays my RGB bulbs (lamps)


Thanks for isolating the issue, I’ll take a look at this today.


The referenced piston 0u4d is using an attribute from a custom device type handler. The query to build out the device list in these dropdowns is not based on the device type but rather on the attribute. So in the case of this piston, the importer will only show devices that have a $status attribute (which for all of us results in no devices).

This could certainly be handled better with a message to let you know why the list is empty, but I don’t think that defaulting to all available devices is a good solution since the $status attribute will not be available and the piston will not work anyway.

If multiple attributes from a device are used the device list will only include those devices that support all required attributes. In the case of ijo7 you would need locks supporting attributes lock and tamper.

Please let me know if you do have devices with all the attributes used in the piston but still do not see them in the list. Also @c1arkbar, what is the backup code for the piston with RGB bulbs?


Oops, previous comment was incorrect on the following:

I should have looked this up first; $status is not from a custom device type handler, it is a pseudo-attribute provided by webCoRE so that certainly should be fixable. I’ll look into this.


I have a fix ready for the problem mentioned above with the $status attribute and noticed that the same issue affects the axisX, axisY, axisZ, and orientation attributes which are all derived from threeAxis.

This will not be released immediately; instead please let me know if there are any other pistons you have noticed that return a blank device list when you in fact have devices with matching attributes.


Ok I’ll keep an eye out. This one was brought to attention by @jkp and I confirmed on the codes he was using.


Restoring devices in pistons that use the $status or axis attributes should be fixed in today’s 0.2.102 update.