Find Lost Pistons?

piston

#1

I was just getting a grasp on creating my own Pistons and then up and sold my house, then moved to a new one. Haven’t started setting up my HA gadgets yet and decided now’s the time for some cleanup in the SmartThings app.
Tried to update my address in SmartThings and no matter what I did, it wouldn’t accept it. It’s new construction and not on maps yet. In a 1 AM sleep deprived state, I made a bonehead move and deleted my “Home” in SmartThings just trying to fix the address.
After I regained the ability to hold my lunch again, I decided since I messed it up, I’ll stick with only the new app. Got WebCore back and realized my Pistons are all gone.
Logging into WebCore, I can’t find any old Pistons. I am not sure how closely tied to the SmartThings “Home” they are, but they seem lost. Just wondering if anyone knows of a way to tell?
I’ve searched the forum already and tried what I could, but coming up empty so far. If they’re gone, so be it. Just wanted to use what I made for my own educational documents for making new Pistons.
Thanks


#2

Tagging @ipaterson


#3

If you used the automatic backup feature we should be able to restore your pistons. The data is encrypted so I can’t help find any specific pistons, but it should be possible to retrieve all of your backup codes. The codes are associated with your SmartThings account ID, so they survive deleting a webCoRE instance.

Please sign in to the webCoRE dashboard for your new webCoRE install and create two new pistons, then send me a private message with the backup codes for those pistons. The two codes should help to unambiguously identify your account and allow me to retrieve the backup codes for the lost pistons.

These private backup codes are encrypted with the account id, so the main reason that webCoRE advises not to share them is that no one else can make use of the code.


Is there any way to recover a piston I accidentally uninstalled without the backup pin?
Deleted wrong instance - any way to recover
Lost Pistons migrating from Classic app to new
Webcore hoplelessly corrupt
Piston is Broken. Can't Open, Pause, or Delete
Cant install WebCORE Smartthings new app or classic
Can't Restore Piston with Backup Code
Blank pistons from back up
#4

PM sent. Thank you!


#5

@ipaterson I have a similar problem, WebCore was deleted by mistake and I don’t have the codes written although all pistons had auto backup. Will you be able to help if I send you 2 codes for newly created pistons? Thanks in advance!


#6

Sure, send away!


#7

For some reason cannot PM you, my user seems to be too new…


#8

@ipaterson any way you can help and unlock my ability to PM?


#9

I seem to have the same problem any chance you could help me?


#10

Just following up to confirm that maxb and gary80 were able to restore pistons.


#11

Is it possible to help me with the same problem? Accidentally deleted my instance.


#12

@ipaterson I find myself in the same boat, hoping you could help me recover my deleted pistons (pretty sure I had auto backup turned on, anyway. I don’t know that I can PM you, not sure that I have enough posts. @webCoRE_Minions


#13

I had to uninstall and reinstall Webcore, it created a new instance and now am unable to access the old instance. I did have auto back up on but I made the mistake of not thinking I needed a back up. If there is anyway anyone can help me that would be wonderful and amazing.

Also, I just made this account in order to post this message and have no idea how to PM or if I can PM but I did create the two blank pistons mentioned in previous posts. But really, I just need the old instance to be my current instance.

Thanks!


#14

@ipaterson I was having a lot of trouble accessing the webcore dashboard recently and ultimately had to resort to uninstalling and reinstalling webcore. In the process I lost all of my existing pistons. Would you be able to help me recover them if I sent you two backup codes? I tried to send you a pm but doesn’t look like I have permission.


#15

@ipaterson My hubitat database got corrupted and I had to do a soft reboot. I lost everything but added a few devices back in and used Hubitat Package manager to install webcore. When I log into webcore a new instance was there and I was no longer able to click on my existing instance. I did have automatic back-ups enabled but I cannot get into the instance with all of my pistons. If you would like I can open a separate request.

Thank you.


#16

Any hubitat backups?

Tagging @E_Sch


#17

Yes but it was from a week ago. When I restored I had nothing in HE and when I added webcore back in I had the issues outlined above.

I had both instances in webcore but when I did a refresh the first instance (with all of my pistons) was greyed out.

https://prnt.sc/26sjgx5


#18

Typically after a soft reset you restore the db

If you have two webcores you should see under he console -> apps -> webcore the piston child apps

You may want ,chat with he support on what you did on the soft reset

You do not want to delete webcore child apps …these are the pistons and you want to back them up before deleting

So proceed carefully and ensure you have he backups before deleting anything


#19

I have a ticket in with support but since the database was corrupt when I restored there was nothing in HE. I only have one Webcore. Since I reinstalled I assumed (wrong I guess) that I would be able to log back into Webcore and see my pistons.

The two instances are on the Webcore side not HE. I did see the pistons but I was not able to select them and a new Webcore version was there likely due to the reinstall.


#20

Normally HE keeps multiple backups, so at least when this initially occurred, you had the option to to select an older backup to restore after the soft reset.

In any case, you have some choices:

a) if you have an older backup or an offline saved backup, you can restore back to that.

b) if you don’t have that, then be careful, to not lose what you have. I suggest you take a backup and save it offline now so you don’t lose what you have.


So there needs to be a more detailed analysis of what you have / don't have....

You likely want to post what you see under

  • HE console -> apps for the webcore’s you have (ie the trees of pistons).

It would be good to see for your previous pistons, what a settings looks like for one of them

This is HE console -> apps -> select the gear icon next to the piston, this could be multiple screen shots.

  • Hopefully you have the piston backup codes there. (this is the field label ‘bin’)

Based on this, can understand

  • what is the current situation
  • what do you have / not have
  • were automatic piston backups enabled, and do you have the bin codes for you pistons here.

@ipaterson may have other thoughts.